Autor Tópico: [Problema] Erro no upgrade ao Worpress 2.8.2  (Lida 1045 vezes)

Offline southafrikanse

  • A noob in a geek world
  • Administrator
  • Newbie
  • *****
  • Mensagens: 0
  • Karma: +0/-0
    • Ver Perfil
    • http://www.tugatronica.com
[Problema] Erro no upgrade ao Worpress 2.8.2
« em: Julho 27, 2009, 12:47:01 pm »
Não estou a conseguir efectuar o upgrade para a nova versão do Wordpress (2.8.2) directamente pelo backend do WP. Obtenho o seguinte erro:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2355661 bytes) in /home/euricole/public_html/wp-includes/http.php on line 1324

Tive o mesmo problema ao fazer upgrade para a versão anterior (2.8.1) e fui forçado a instalar a nova versão manualmente.

Desinstalei alguns plugins que já estavam inutilizados, removi também 5 temas que tinha instalado para testar, optimizei as tabelas da minha base de dados (a quantidade de lixo que tinha meu Deus). Depois, ao consultar no cpanel, deparo-me com isto:


Ora bem, parto do princípio pela descrição do erro que deixei de ter memória disponível para ele instalar a nova versão. No entanto, porque é que isto acontece agora quando antes funcionava?
Blog Pessoal | Tugatrónica | Fórum Webtuga
"Knowledge is knowing that a tomato is a fruit, but Wisdom is knowing not to put it in a fruit salad."

Offline Teotónio Ricardo

  • Administrator
  • Newbie
  • *****
  • Mensagens: 0
  • Karma: +0/-0
    • Ver Perfil
    • http://www.teotonio.pt
[Problema] Erro no upgrade ao Worpress 2.8.2
« Responder #1 em: Julho 27, 2009, 12:54:01 pm »
O que acontece é que as ultimas versões do Wordpress estão pesadíssimas e quem usa determinados plugins, vai-se deparar com este erro.

Este erro é provocado pelo consumo excessivo de recursos pelo Wordpress, ultrapassando o limite de memória utilizada.

São bastantes as pessoas a queixarem-se, no entanto se verificarem os plugins e alguns problemas que o Wordpress possa ter, conseguem correr facilmente o Wordpress sem ter este problema.

O WebTuga e todos os sites da rede correm com a configuração normal de 32MB de memory_limit e não tenho tido grandes problemas.

Offline badpunchline

  • Newbie
  • *
  • Mensagens: 0
  • Karma: +0/-0
    • Ver Perfil
[Problema] Erro no upgrade ao Worpress 2.8.2
« Responder #2 em: Julho 27, 2009, 01:15:40 pm »
Sim também tive este problema na versão anterior, e tive que andar a remover alguns plugins para o poder fazer automaticamente. Isto também costuma acontecer ao actualizar certos plugins directamente pelo wp-admin :http://www.webtuga.com/forum/public/style_emoticons/<#EMO_DIR#>/smile.png\' class=\'bbc_emoticon\' alt=\':)\' />
while(1){
      cout << "FAIL" << endl;
}

Offline Teotónio Ricardo

  • Administrator
  • Newbie
  • *****
  • Mensagens: 0
  • Karma: +0/-0
    • Ver Perfil
    • http://www.teotonio.pt
[Problema] Erro no upgrade ao Worpress 2.8.2
« Responder #3 em: Julho 27, 2009, 01:19:14 pm »
A ultima versão parece não ter tantos problemas, lembro-me de ter de alterar o class.wp-http.php para conseguir fazer upgrade automático também.

Offline southafrikanse

  • A noob in a geek world
  • Administrator
  • Newbie
  • *****
  • Mensagens: 0
  • Karma: +0/-0
    • Ver Perfil
    • http://www.tugatronica.com
[Problema] Erro no upgrade ao Worpress 2.8.2
« Responder #4 em: Julho 27, 2009, 02:20:24 pm »
Faltou dizer que tentei instalar a nova versão com os plugins desactivados e o problema acontece-me na mesma.

Então a solução passa por editar o dito ficheiro? Se sim, onde?
Blog Pessoal | Tugatrónica | Fórum Webtuga
"Knowledge is knowing that a tomato is a fruit, but Wisdom is knowing not to put it in a fruit salad."

Offline trmanco

  • Global Moderator
  • Newbie
  • *****
  • Mensagens: 0
  • Karma: +0/-0
    • Ver Perfil
    • http://trmanco.com
[Problema] Erro no upgrade ao Worpress 2.8.2
« Responder #5 em: Julho 27, 2009, 03:05:26 pm »
Insere isto no wp-config.php, pode ser que resulte :-P

Código: [Seleccione]
define(’WP_MEMORY_LIMIT’, ‘64’);

Offline Teotónio Ricardo

  • Administrator
  • Newbie
  • *****
  • Mensagens: 0
  • Karma: +0/-0
    • Ver Perfil
    • http://www.teotonio.pt
[Problema] Erro no upgrade ao Worpress 2.8.2
« Responder #6 em: Julho 27, 2009, 04:14:54 pm »
Podes também criar um ficheiro php.ini e colocar esta linha lá dentro:

Código: [Seleccione]
memory_limit = 64M
Ou colocar esta linha no .htaccess

Código: [Seleccione]
php_value memory_limit 64M
Ou ainda este código dentro do wp-config.php

Código: [Seleccione]
ini_set('memory_limit', '64M');
Mas mais uma vez, aumentar o memory_limit não é solução para tudo... 32M são mais que suficientes para um blog normal...

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49